Ошибка в WordPress: Warning: Cannot modify header information

Как всегда неожиданно на одном из сайтов, созданных на базе WordPress всплыла ошибка:

Warning: Cannot modify header information — headers already sent by (output started at /servername/public_html/wp-config.php:1) in /servername/public_html/wp-includes/pluggable.php on line 1207

Ковыряние в Гугле привело к следующему решению: проблема лежит в ошибке кодировке файла. Ну бывает такое — правил файл-правил, а потом бах, и сохранил либо не в UTF-8. Наиболее правильным (для начала) будет открыть Notepad++ и открыв искомый файл (перед этим его нужно слить на локальный компьютер с хостинга) пересохранить в UTF-8 без BOM. В Notepad++ это делается следующим образом: верхнее меню — Кодировки — Преобразовать в UTF-8 без BOM, после чего сохранить файл.
notepad-bom

Закачиваем файл на сервер, и (скорее всего) — ошибка пропадает.

Как всегда — в случае возникновения вопросов — пожалуйста, пишите на почту oleksiy@lavrynenko.com

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *